aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <[email protected]>2023-03-03 20:48:15 -0500
committerMorph <[email protected]>2023-03-05 02:36:31 -0500
commit3453beb1e0fa7af3db4e07418f3ea8d997d005be (patch)
treef155db87b8b1e2d497d148a49b848f68bea8bff9 /CMakeLists.txt
parent194cf0b4974f088dbcf0df879e44e767b3ab4450 (diff)
downloadyuzu-android-3453beb1e0fa7af3db4e07418f3ea8d997d005be.tar.gz
yuzu-android-3453beb1e0fa7af3db4e07418f3ea8d997d005be.zip
general: Target Windows 10 SDK
We no longer support operating systems below Windows 10.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f26a0c6b8..91ec50bef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -477,8 +477,8 @@ if (APPLE)
find_library(COCOA_LIBRARY Cocoa)
set(PLATFORM_LIBRARIES ${COCOA_LIBRARY} ${IOKIT_LIBRARY} ${COREVIDEO_LIBRARY})
elseif (WIN32)
- # WSAPoll and SHGetKnownFolderPath (AppData/Roaming) didn't exist before WinNT 6.x (Vista)
- add_definitions(-D_WIN32_WINNT=0x0600 -DWINVER=0x0600)
+ # Target Windows 10
+ add_definitions(-D_WIN32_WINNT=0x0A00 -DWINVER=0x0A00)
set(PLATFORM_LIBRARIES winmm ws2_32 iphlpapi)
if (MINGW)
# PSAPI is the Process Status API