aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <[email protected]>2023-07-25 15:47:44 -0400
committerlat9nq <[email protected]>2023-07-25 15:47:44 -0400
commit43920aa1a01e7592d1fe93ee5b33a57b5413accf (patch)
tree916e63b24f9a8d3cab07a3db604ae8cd0c589bc2 /CMakeLists.txt
parent18000df5e968af0aa9784f398a97da2733262126 (diff)
downloadyuzu-android-43920aa1a01e7592d1fe93ee5b33a57b5413accf.tar.gz
yuzu-android-43920aa1a01e7592d1fe93ee5b33a57b5413accf.zip
cmake: Download nasm from our external repo
This package download has intermittent failures due to host Internet issues (presumably), so download it ourselves from our own hosting.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00d540f1f..af9f394f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -136,6 +136,22 @@ if (YUZU_USE_BUNDLED_VCPKG)
endif()
endif()
+ if (MSVC)
+ set(VCPKG_DOWNLOADS_PATH ${PROJECT_SOURCE_DIR}/externals/vcpkg/downloads)
+ set(NASM_VERSION "2.16.01")
+ set(NASM_DESTINATION_PATH ${VCPKG_DOWNLOADS_PATH}/nasm-${NASM_VERSION}-win64.zip)
+ set(NASM_DOWNLOAD_URL "https://github.com/yuzu-emu/ext-windows-bin/raw/master/nasm/nasm-${NASM_VERSION}-win64.zip")
+
+ if (NOT EXISTS ${NASM_DESTINATION_PATH})
+ file(DOWNLOAD ${NASM_DOWNLOAD_URL} ${NASM_DESTINATION_PATH} SHOW_PROGRESS STATUS NASM_STATUS)
+
+ if (NOT NASM_STATUS EQUAL 0)
+ # Warn and not fail since vcpkg is supposed to download this package for us in the first place
+ message(WARNING "External nasm vcpkg package download from ${NASM_DOWNLOAD_URL} failed with status ${NASM_STATUS}")
+ endif()
+ endif()
+ endif()
+
if (YUZU_TESTS)
list(APPEND VCPKG_MANIFEST_FEATURES "yuzu-tests")
endif()