aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorcomex <[email protected]>2023-06-25 14:57:34 -0700
committercomex <[email protected]>2023-06-25 15:06:52 -0700
commit4a355699219710d0a9ad620722393b3d9a16d84d (patch)
tree69b5d25adffe30e968bdcd47c367e0c1040c4427 /CMakeLists.txt
parent8905142f4362e06bd8f0a35cf9887d5110c1f308 (diff)
downloadyuzu-android-4a355699219710d0a9ad620722393b3d9a16d84d.tar.gz
yuzu-android-4a355699219710d0a9ad620722393b3d9a16d84d.zip
Fixes:
- Add missing virtual destructor on `SSLBackend`. - On Windows, filter out `POLLWRBAND` (one of the new flags added) when calling `WSAPoll`, because despite the constant being defined on Windows, passing it calls `WSAPoll` to yield `EINVAL`. - Reduce OpenSSL version requirement to satisfy CI; I haven't tested whether it actually builds (or runs) against 1.1.1, but if not, I'll figure it out. - Change an instance of memcpy to memmove, even though the arguments cannot overlap, to avoid a [strange GCC error](https://github.com/yuzu-emu/yuzu/pull/10912#issuecomment-1606283351).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c44febbc2..bd3808515 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -325,7 +325,7 @@ if (MINGW)
endif()
if(ENABLE_OPENSSL)
- find_package(OpenSSL 3.0.0 REQUIRED)
+ find_package(OpenSSL 1.1.1 REQUIRED)
endif()
# Please consider this as a stub