aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <[email protected]>2023-09-12 09:17:50 -0400
committerGitHub <[email protected]>2023-09-12 09:17:50 -0400
commitce5320c49f6e3c1dc52b9046213366dd0df1612f (patch)
tree58d116258d42771a5ccda31775b127113b1ea256 /CMakeLists.txt
parent66f2947854f993f9d907ddc9c23f7e28aa12f330 (diff)
parenta02d641042d031999f3b4b90a2b5190417e051c5 (diff)
downloadyuzu-android-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar.gz
yuzu-android-ce5320c49f6e3c1dc52b9046213366dd0df1612f.zip
Merge pull request #11447 from xcfrg/portable-compile-out
common: add a compile time option to allow disabling portable mode
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c6b158985..3b0891adf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,6 +63,8 @@ option(YUZU_ENABLE_LTO "Enable link-time optimization" OFF)
option(YUZU_DOWNLOAD_TIME_ZONE_DATA "Always download time zone binaries" OFF)
+option(YUZU_ENABLE_PORTABLE "Allow yuzu to enable portable mode if a user folder is found in the CWD" ON)
+
CMAKE_DEPENDENT_OPTION(YUZU_USE_FASTER_LD "Check if a faster linker is available" ON "NOT WIN32" OFF)
CMAKE_DEPENDENT_OPTION(USE_SYSTEM_MOLTENVK "Use the system MoltenVK lib (instead of the bundled one)" OFF "APPLE" OFF)