aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <[email protected]>2023-06-06 20:19:44 -0400
committerMorph <[email protected]>2023-06-06 20:20:09 -0400
commitf62f43c0dae041b1a7dd282d3f1c055fa7038649 (patch)
tree1b5469eb2a1bf536d4fa3ab061cf4a205cabbc51 /CMakeLists.txt
parent238e46ec9339e1f4e8b3fb565b2c8679f14a47ff (diff)
downloadyuzu-android-f62f43c0dae041b1a7dd282d3f1c055fa7038649.tar.gz
yuzu-android-f62f43c0dae041b1a7dd282d3f1c055fa7038649.zip
CMakeLists: Force C++20 on MSVC due to conflicts with C++23 modules
The latest version of MSVC STL brings C++23 standard library modules, which conflict with precompiled headers. Disabling with /experimental:module- has no effect, so force C++20 in the meantime while we wait for module support in other compilers.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 30a3c939e..3d03bbf94 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -255,7 +255,7 @@ endif()
# boost asio's concept usage doesn't play nicely with some compilers yet.
add_definitions(-DBOOST_ASIO_DISABLE_CONCEPTS)
if (MSVC)
- add_compile_options($<$<COMPILE_LANGUAGE:CXX>:/std:c++latest>)
+ add_compile_options($<$<COMPILE_LANGUAGE:CXX>:/std:c++20>)
# boost still makes use of deprecated result_of.
add_definitions(-D_HAS_DEPRECATED_RESULT_OF)