aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorliushuyu <[email protected]>2023-03-04 00:05:17 -0700
committerbunnei <[email protected]>2023-06-03 00:05:33 -0700
commit19eec22b38d37711951ea7549a6ea77c449a81a2 (patch)
tree4b7d4f0f5d09acf4fa3f5d2e75d0e830996d9b1c /CMakeLists.txt
parent1d0329a065f627de17c97ff5224dfc90504b83f8 (diff)
downloadyuzu-mainline-19eec22b38d37711951ea7549a6ea77c449a81a2.tar.gz
yuzu-mainline-19eec22b38d37711951ea7549a6ea77c449a81a2.zip
CMake: fix pkg-config behavior when building for Android
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bcd88784b..2d25cc3a9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -108,6 +108,9 @@ if (YUZU_USE_BUNDLED_VCPKG)
if (ANDROID)
set(VCPKG_TARGET_TRIPLET "arm64-android")
set(ENV{ANDROID_NDK_HOME} "${ANDROID_NDK}")
+ # this is to avoid CMake using the host pkg-config to find the host
+ # libraries when building for Android targets
+ set(PKG_CONFIG_EXECUTABLE "aarch64-none-linux-android-pkg-config" CACHE FILEPATH "" FORCE)
list(APPEND VCPKG_MANIFEST_FEATURES "android")
endif()