aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <[email protected]>2023-11-30 09:20:55 -0500
committerGitHub <[email protected]>2023-11-30 09:20:55 -0500
commit57a391e71db13ade7a3d96f59d53781eff18d2ac (patch)
tree0b4223de40a2d77598ac9095b1374353c2e9da7c /CMakeLists.txt
parent9dc9aaf4af1c3c846c9cd46a9433dcf0684da19b (diff)
parent4a3abba16d9821ed163aab427d4c7bc9ef7acb32 (diff)
downloadyuzu-mainline-57a391e71db13ade7a3d96f59d53781eff18d2ac.tar.gz
yuzu-mainline-57a391e71db13ade7a3d96f59d53781eff18d2ac.zip
Merge pull request #12074 from GPUCode/yuwu-on-the-metal
Implement Native Code Execution (NCE)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ec7975b87..599f7c831 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -260,6 +260,11 @@ if (UNIX)
add_definitions(-DYUZU_UNIX=1)
endif()
+if (ARCHITECTURE_arm64 AND (ANDROID OR ${CMAKE_SYSTEM_NAME} STREQUAL "Linux"))
+ set(HAS_NCE 1)
+ add_definitions(-DHAS_NCE=1)
+endif()
+
# Configure C++ standard
# ===========================