aboutsummaryrefslogtreecommitdiffhomepage
path: root/externals/opus/CMakeLists.txt
diff options
context:
space:
mode:
authorMarkus Wick <[email protected]>2021-04-08 23:49:32 +0200
committerMarkus Wick <[email protected]>2021-04-08 23:49:32 +0200
commit5096ed5e0ab91254a29a58234d1df71b4065745f (patch)
treecd7ca8a690d42792f753a300c9ffcc0c9151629b /externals/opus/CMakeLists.txt
parentdfac2e2d25c18e96a437561e6528b92a82887b32 (diff)
downloadyuzu-mainline-5096ed5e0ab91254a29a58234d1df71b4065745f.tar.gz
yuzu-mainline-5096ed5e0ab91254a29a58234d1df71b4065745f.zip
externals: Search for shared opus installation.
We had used conan for opus before, but there was a bug in the AVX detection. However we still had the Findopus.cmake file within the repository, but not used. This patch reenables the Findopus helper and prefer the system wide installation of opus.
Diffstat (limited to 'externals/opus/CMakeLists.txt')
-rw-r--r--externals/opus/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/externals/opus/CMakeLists.txt b/externals/opus/CMakeLists.txt
index 94a86551f..16f5af9f2 100644
--- a/externals/opus/CMakeLists.txt
+++ b/externals/opus/CMakeLists.txt
@@ -252,3 +252,5 @@ PRIVATE
opus/silk/float
opus/src
)
+
+add_library(Opus::Opus ALIAS opus)