aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <[email protected]>2020-08-03 11:03:30 -0400
committerLioncash <[email protected]>2020-08-03 11:21:24 -0400
commitdd2ff236217cb02275cbfa66f50c265a578d1f1e (patch)
tree39f2fbf829fa9fd949103862a75ff3594ca3a6b3 /src/CMakeLists.txt
parent9b75481755c8d566bc666465d659115bba2b2578 (diff)
downloadyuzu-mainline-dd2ff236217cb02275cbfa66f50c265a578d1f1e.tar.gz
yuzu-mainline-dd2ff236217cb02275cbfa66f50c265a578d1f1e.zip
CMakeLists: Resolve #4478
This switch is enabled by default in all recent versions of GCC and Clang.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 54dca3302..71efbb40d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -60,9 +60,14 @@ else()
-Wmissing-declarations
-Wno-attributes
-Wno-unused-parameter
- -fconcepts
)
+ # TODO: Remove when we update to a GCC compiler that enables this
+ # by default (i.e. GCC 10 or newer).
+ if (CMAKE_CXX_COMPILER_ID STREQUAL GNU)
+ add_compile_options(-fconcepts)
+ endif()
+
if (ARCHITECTURE_x86_64)
add_compile_options("-mcx16")
endif()