aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorNarr the Reg <[email protected]>2022-12-20 11:34:33 -0600
committerNarr the Reg <[email protected]>2023-01-19 18:05:20 -0600
commitd80e6c399bf8196646cca5ac1265d122638bb96b (patch)
tree328254642e4edcd5e0aadfe9190f3f133d34708e /src/input_common/CMakeLists.txt
parent475370c8f89002e3b508eb152b981a5b89049d68 (diff)
downloadyuzu-mainline-d80e6c399bf8196646cca5ac1265d122638bb96b.tar.gz
yuzu-mainline-d80e6c399bf8196646cca5ac1265d122638bb96b.zip
input_common: Initial skeleton for custom joycon driver
Diffstat (limited to 'src/input_common/CMakeLists.txt')
-rw-r--r--src/input_common/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index cef2c4d52..41885d0d2 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -51,8 +51,13 @@ endif()
if (ENABLE_SDL2)
target_sources(input_common PRIVATE
+ drivers/joycon.cpp
+ drivers/joycon.h
drivers/sdl_driver.cpp
drivers/sdl_driver.h
+ helpers/joycon_driver.cpp
+ helpers/joycon_driver.h
+ helpers/joycon_protocol/joycon_types.h
)
target_link_libraries(input_common PRIVATE SDL2::SDL2)
target_compile_definitions(input_common PRIVATE HAVE_SDL2)