aboutsummaryrefslogtreecommitdiffhomepage
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Johanson <[email protected]>2022-02-01 03:29:50 +0000
committerPete Johanson <[email protected]>2022-01-31 23:03:34 -0500
commit74307504280573aae5819afad29aceaf97b8344e (patch)
tree6b9face3d9f539d4b5b4f5f41f377f6ebe402123 /app/CMakeLists.txt
parentb8700eaaa1e24837d6b9ff60430d706c555f9a2f (diff)
downloadzmk-74307504280573aae5819afad29aceaf97b8344e.tar.gz
zmk-74307504280573aae5819afad29aceaf97b8344e.zip
refactor(splits): Minor cleanups to periph invocation
* Add strlcpy from public domain version. * Leverage strlcpy to detect truncation of behavior dev strs, and log. * Use `offsetof` for cleaner detection on peripheral side.
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index 1e153fb630..7681efab68 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -23,6 +23,7 @@ zephyr_linker_sources(RODATA include/linker/zmk-events.ld)
# find_package(Zephyr) which defines the target.
target_include_directories(app PRIVATE include)
target_sources_ifdef(CONFIG_ZMK_SLEEP app PRIVATE src/power.c)
+target_sources(app PRIVATE src/stdlib.c)
target_sources(app PRIVATE src/activity.c)
target_sources(app PRIVATE src/kscan.c)
target_sources(app PRIVATE src/matrix_transform.c)