aboutsummaryrefslogtreecommitdiffhomepage
path: root/nix/default.nix
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-11-07 10:52:12 +0200
committerMihai Fufezan <[email protected]>2024-11-07 10:52:12 +0200
commited729b41319cc1129d5380d6e1055db60f01ea9d (patch)
tree3ad76b4c3023a836abd65376205aac91cc0e2939 /nix/default.nix
parent86a3d41051515f416f5eef2d4b6076ac2e8d16af (diff)
downloadHyprland-keepDebugInfo.tar.gz
Hyprland-keepDebugInfo.zip
Nix: build aquamarine and hyprutils in debug when using hyprland-debugkeepDebugInfo
Diffstat (limited to 'nix/default.nix')
-rw-r--r--nix/default.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/nix/default.nix b/nix/default.nix
index d463e271..29d31485 100644
--- a/nix/default.nix
+++ b/nix/default.nix
@@ -56,6 +56,7 @@
adapters = flatten [
stdenvAdapters.useMoldLinker
+ (lib.optional debug stdenvAdapters.keepDebugInfo)
];
customStdenv = foldl' (acc: adapter: adapter acc) stdenv adapters;
@@ -147,9 +148,6 @@ in
then "debugoptimized"
else "release";
- # we want as much debug info as possible
- dontStrip = debug;
-
mesonFlags = flatten [
(mapAttrsToList mesonEnable {
"xwayland" = enableXWayland;