aboutsummaryrefslogtreecommitdiffhomepage
path: root/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/default.nix')
-rw-r--r--nix/default.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/nix/default.nix b/nix/default.nix
index d463e271..29d31485 100644
--- a/nix/default.nix
+++ b/nix/default.nix
@@ -56,6 +56,7 @@
adapters = flatten [
stdenvAdapters.useMoldLinker
+ (lib.optional debug stdenvAdapters.keepDebugInfo)
];
customStdenv = foldl' (acc: adapter: adapter acc) stdenv adapters;
@@ -147,9 +148,6 @@ in
then "debugoptimized"
else "release";
- # we want as much debug info as possible
- dontStrip = debug;
-
mesonFlags = flatten [
(mapAttrsToList mesonEnable {
"xwayland" = enableXWayland;