aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Pappacoda <[email protected]>2022-11-24 16:36:55 +0100
committermerry <[email protected]>2022-11-24 16:09:13 +0000
commit7414f76ce92acb8abe4021a9297f90a4cee29a3a (patch)
treea0f14b8a1680a61085d16b23dbad764b35444f29 /CMakeLists.txt
parenta5b57bb9cd1500a6e0a3c800b35c1984211dff1d (diff)
downloaddynarmic-7414f76ce92acb8abe4021a9297f90a4cee29a3a.tar.gz
dynarmic-7414f76ce92acb8abe4021a9297f90a4cee29a3a.zip
build: only require Zydis on x86
Zydis is only used on x86, and this patch allows compilation on ARM without Zydis installed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf3e69a5..9a8c4acf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -139,8 +139,10 @@ if (DYNARMIC_NO_BUNDLED_XBYAK AND NOT TARGET xbyak)
endif()
if (DYNARMIC_NO_BUNDLED_ZYDIS AND NOT TARGET Zydis)
- find_package(Zydis REQUIRED)
- add_library(Zydis ALIAS Zydis::Zydis)
+ if (ARCHITECTURE STREQUAL "x86" OR ARCHITECTURE STREQUAL "x86_64")
+ find_package(Zydis REQUIRED)
+ add_library(Zydis ALIAS Zydis::Zydis)
+ endif()
endif()
# Enable unit-testing.