aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authornia <[email protected]>2019-06-11 23:35:08 +0100
committerMatthew Gregan <[email protected]>2019-06-12 10:35:08 +1200
commit9f39687e7fa8ad98604334cda512d27b6bf93092 (patch)
tree535e2c4dae383f51d4edd335fab2aaefacc53846 /CMakeLists.txt
parent03eb237c3bd484d53c34c0cb55f95b65f95ec965 (diff)
downloadcubeb-9f39687e7fa8ad98604334cda512d27b6bf93092.tar.gz
cubeb-9f39687e7fa8ad98604334cda512d27b6bf93092.zip
sunaudio (NetBSD/illumos) backend (#510)
* Initial support. Device scanning and sanity checks work. Playback and recording does not. * stream_init fixes. Audio test now runs, though doesn't do anything. * Set the prinfo type to the device type we'll later be limited to. * Playback support. Also implement stream_get_current_device and stream_device_destroy. * AUDIO_SETINFO properly. * Don't poll forever when recording. Use the recommended number of latency_frames as our BUFSIZE. * Fix typo. * Don't allocate devid. Required for a sanity test. * Fix some tests * Initial attempt to support Solaris * stdlib.h for calloc. * undo local change * Should probably be using "events" here, and the state change isn't necessary now that it's done elsewhere. * Avoid format truncation warning. * more illumos fixes * Performance improvements. It seems polling for input is not a viable strategy. * Protect volume and frames_written with a mutex. * Protect running with a mutex.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92c876c..82ffc99 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -225,6 +225,14 @@ if(USE_SNDIO)
target_link_libraries(cubeb PRIVATE sndio)
endif()
+check_include_files(sys/audioio.h USE_SUN)
+if(USE_SUN)
+ target_sources(cubeb PRIVATE
+ src/cubeb_sun.c)
+ target_compile_definitions(cubeb PRIVATE USE_SUN)
+ target_link_libraries(cubeb PRIVATE pthread)
+endif()
+
check_include_files(kai.h USE_KAI)
if(USE_KAI)
target_sources(cubeb PRIVATE