aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92c876c..82ffc99 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -225,6 +225,14 @@ if(USE_SNDIO)
target_link_libraries(cubeb PRIVATE sndio)
endif()
+check_include_files(sys/audioio.h USE_SUN)
+if(USE_SUN)
+ target_sources(cubeb PRIVATE
+ src/cubeb_sun.c)
+ target_compile_definitions(cubeb PRIVATE USE_SUN)
+ target_link_libraries(cubeb PRIVATE pthread)
+endif()
+
check_include_files(kai.h USE_KAI)
if(USE_KAI)
target_sources(cubeb PRIVATE